I can connect to the VPN, but my speeds are really slow using Windows

Under some rare circumstances, newer versions of the TAP driver for some versions of Windows can cause slowdowns and render the Internet practically unbrowsable using any OpenVPN based service. The details of why it acts this way are not known, but there are several reports of people saying that downgrading to the last NDIS 5 version of the driver significantly improved the situation.

If you believe this is your case, or just want to try it anyway, please follow these instructions:

  1. Make sure the VPN software is not running:

    1. Right click the PIA icon in the system tray (Info: The system tray is the list of icons on the bottom right of your screen on the left of the clock. You may need to click on the little arrow to show more icons.)
    2. Click Exit
  2. Uninstall the TAP driver from the device manager

    1. Press and hold the Windows key, followed by R on your keyboard. This will open the "Run" dialog window.
    2. Type in devmgmt.msc and press OK or hit the Enter key on your keyboard. The device manager window should appear after a few seconds.
    3. Click on the > arrow next to the Network Adapters section.
    4. Right click on the adapter listed as TAP-Windows Adapter V9 #2
    5. Click Uninstall
    6. Check the box for Delete the driver software for this device
    7. Click OK
      Note: If there are any other "TAP" Adapters listed here please uninstall them in the same manner - Ex. TAP-Win32 Adapter. If you do not see any "TAP" Adapters listed here, look into the Other Devices or Unknown Devices sections in case any TAP adapters are there. If you cannot see any TAP adapter in any sections of this window, it is safe to assume you do not have the TAP adapter installed and you can safely continue to the next section.
  3. Install the older version of the OpenVPN TAP driver

    1. Download this particular build: https://swupdate.openvpn.org/community/releases/tap-windows-9.9.2_3.exe
    2. Run the installer - it should only contain one component, so you can just click next and install the defaults as they are
  4. Launch the PIA application again and check if the speeds have improved!

If these steps didn't work for you, you can simply reinstall the PIA application. It will automatically reinstall our latest version of the TAP driver.

Have more questions? Submit a request